Issue Details (XML | Word | Printable)

Key: MBS-7696
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Normal Normal
Assignee: Ulrich Klauer
Reporter: HibiscusKazeneko
Votes: 1
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

"This attribute type is only used for grouping, please select a subtype" when editing works

Created: 23/Jun/14 08:15 PM   Updated: 07/Jul/14 07:54 PM  Due: 07/Jul/14   Resolved: 07/Jul/14 07:54 PM
Component/s: Editing interface
Affects Version/s: None
Fix Version/s: 2014-07-07

File Attachments: None
Image Attachments:

1. Screen Shot 2014-06-23 at 3.14.01 PM.png
(34 kB)
Issue Links:
Relates
 


 Description  « Hide

This text shows up when I try to edit a work. It went away for a while but suddenly reappeared! All I have to do to trigger it is click the "Edit" tab on a work's page in the regular server. It disables the drop-down menus at the top of the page, locks up the work attribute selection bar and blocks any edits from going through.
I know this is suspicious because there are no grouping types in the work attributes menu. Did someone leave a scrap of code behind or is there something else going on?



Sort Order: Ascending order - Click to sort in descending order
Ulrich Klauer added a comment - 23/Jun/14 08:28 PM

I can reproduce this on a test database that does not have any work attribute types, but not on the regular server.


HibiscusKazeneko added a comment - 23/Jun/14 08:44 PM

Hmm, so maybe it means my browser didn't load the list?


nikki added a comment - 25/Jun/14 01:13 PM

Can you still reproduce this? If so, could you provide more details about the browser/OS you're using?


HibiscusKazeneko added a comment - 25/Jun/14 01:22 PM

It's difficult to reproduce. It used to be common, but it went away for a while, then it came back.
I'm running OSX 10.9.3 and using Google Chrome version 35.0.1916.153. (I have a few privacy-enhancing extensions running, but I don't know if that affects anything.)


Ulrich Klauer added a comment - 25/Jun/14 01:48 PM

When I get this (as I said before, only on a test database where the work_attribute_type table is empty), I see a browser message that children is undefined in root/static/scripts/edit/forms.js line 15. It would be interesting to know if the same or a different message appears when the bug occurs "in the wild".



Ian McEwen added a comment - 29/Jun/14 07:48 PM

As commented on the PR, it may not fix the underlying problem, but that PR is merged. If you see this again and have more details, we can reopen or create a new ticket.