Issue Details (XML | Word | Printable)

Key: MBS-5696
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Normal Normal
Assignee: Oliver Charles
Reporter: Oliver Charles
Votes: 1
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

ModBot can fail to close 'edit artist' edits that violate uniqueness on (name, comment).

Created: 17/Dec/12 04:25 PM   Updated: 13/Feb/13 10:50 PM   Resolved: 11/Feb/13 11:40 AM
Component/s: None
Affects Version/s: None
Fix Version/s: 2013-02-11

Issue Links:
Duplicate
 
Relates
 


 Description  « Hide

For example, the edit http://musicbrainz.org/edit/19813802 is stuck, because at the time of application there was another artist called 'August Heinrich Wenck' with no disambiguation comment.



Sort Order: Ascending order - Click to sort in descending order
nikki added a comment - 17/Dec/12 05:25 PM

Isn't this just a duplicate of MBS-5585? It's the same problem, it's just that auto-editors get the error immediately while non-auto-editors get edits which can't be applied.


Oliver Charles added a comment - 17/Dec/12 10:41 PM

Not quite, because this actually crashes in ModBot. I imagine it will get resolved at the same time, though it sounds like the other issue needs some sort of check before entering the edit.


Oliver Charles added a comment - 25/Jan/13 04:20 PM

Ian McEwen added a comment - 13/Feb/13 10:50 PM

This fix seems to be what's caused the error listed at MBS-5873.