Issue Details (XML | Word | Printable)

Key: MBS-5655
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Normal Normal
Assignee: Oliver Charles
Reporter: humhumxx
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

It's possible to "Remove [a] release label" although there's none

Created: 07/Dec/12 04:48 PM   Updated: 11/Feb/13 11:40 AM   Resolved: 11/Feb/13 11:40 AM
Component/s: None
Affects Version/s: None
Fix Version/s: 2013-02-11


 Description  « Hide

See http://musicbrainz.org/edit/19885525

Maybe it was just whitespace in the cat# field.



Sort Order: Ascending order - Click to sort in descending order
nikki added a comment - 07/Dec/12 08:03 PM

I can't reproduce this. Can you give some more information about how entered the edit?

It shouldn't be possible to have a catalogue number that's only whitespace now, so that shouldn't be the reason.


humhumxx added a comment - 07/Dec/12 11:23 PM

What I know is that the release had a bullet point in the sidebar under "Label", that's what made me suspicious in the first place. The editing history tells me that in http://musicbrainz.org/edit/19361332 I did not remove the label but simply blanked the field which perhaps didn't do the job the way I had expected it to. Only in http://musicbrainz.org/edit/19885525 I clicked on the red cross to remove it.


humhumxx added a comment - 12/Dec/12 10:51 PM

Has happened again, see http://musicbrainz.org/release/edb1380b-90d3-428a-9dc5-b095768c990a/edits and yes, it's because I once again blanked the label field instead of removing the label entry.


Oliver Charles added a comment - 22/Jan/13 05:49 PM

I think you might be removing something that is in this:

select count(*) from release_label where label is null and catalog_number is null;
 count 
-------
    76

Oliver Charles added a comment - 25/Jan/13 11:35 AM

@HumHumXX: "and yes, it's because I once again blanked the label field instead of removing the label entry" - could you clarify this in a bunch of steps I can use to reproduce entering these failed rows? We will have a constraint soon that will prevent this from happening soon, but I think it might still be possible to submit a form that will cause an exception.


humhumxx added a comment - 25/Jan/13 01:37 PM

Which server can I use for this? Test isn't working as I don't seem to have auto-editor privileges there. On the main server, removing or editing a label is an auto-edit, on test it's not.


Nicolás Tamargo added a comment - 25/Jan/13 01:47 PM

You can give yourself auto-editor privileges on test - just go to your profile and click Edit User. Of course, since test is insanely slow, that might still be a pain to check while getting timeouts - other option is probably to try in one of our sandboxes, where you can also edit your privileges. Try http://reosarevok.mbsandbox.org/


humhumxx added a comment - 25/Jan/13 02:44 PM

Thanks, I did it on test, it's very responsive, actually.

1. Go to any release, e.g. http://test.musicbrainz.org/release/cedcb155-d95d-4630-ab27-e5518ebd3f2b
2. "Edit"
3. Blank the label field (+ the cat#, if available)
4. "Edit Note"
5. "Enter edit"
6. "Edit"
7. Press "X" to remove the label
8. "Edit Note"
9. "Enter edit"
10. Ta-daa!

That's it. Tested with Opera 12.12 and Firefox 18 on Debian Wheezy.

As you can see, I left the release in a state where there's only a bullet point but no label. I can re-add a label, then blank the field again and then remove the label that isn't there again. It always shows the same behaviour.


Oliver Charles added a comment - 25/Jan/13 05:12 PM