Issue Details (XML | Word | Printable)

Key: MBS-3457
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Normal Normal
Assignee: Ian McEwen
Reporter: voiceinsideyou
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Direct search results incorrectly reports a recording as "standalone"

Created: 17/Sep/11 04:11 AM   Updated: 11/Feb/13 11:40 AM   Resolved: 11/Feb/13 11:40 AM
Component/s: Search
Affects Version/s: None
Fix Version/s: 2013-02-11

File Attachments: None
Image Attachments:

1. Every Day Is Exactly The Same Error.jpg
(130 kB)


 Description  « Hide

http://musicbrainz.org/search?query=Love+Is+Not+Enough+&type=recording&limit=25&direct=1

Love Is Not Enough (Live at Rehearsals) says it is a "standalone recording"

This is not correct; it's on two releases: http://musicbrainz.org/recording/0089ac6d-dadc-4755-a410-404e5e3daca8



Sort Order: Ascending order - Click to sort in descending order
voiceinsideyou added a comment - 17/Sep/11 04:15 AM

Not sure if it's related, but worth noting that the same two releases that should be displayed of "Beside You in Time" also have different recordings of "Love Is Not Enough" on them - you can see the "Beside You In Time live version" in the search entry just above the "incorrect" one.


voiceinsideyou added a comment - 20/Feb/12 03:11 PM - edited

The original example here is fixed, because the recording was merged.

Here's another (current) example of this:

http://musicbrainz.org/search?query=Every+Day+Is+Exactly+the+Same&type=recording&limit=25&method=direct
(edited to correct link Sep 26th 2012)

None of these three results are standalone recordings.


Oliver Charles added a comment - 25/Sep/12 03:55 PM

None of these links allow me to reproduce this behaviour, so I'm closing as wontfix. If you can reproduce this, please provide an example link or steps to reproduce it.


voiceinsideyou added a comment - 25/Sep/12 04:51 PM

That's because you guys changed the syntax from direct=1 to method=direct so the 20 Feb link doesn't work anymore. It's trivial to see this - I think you're being too eager to close old tickets.

http://musicbrainz.org/search?query=Every+Day+Is+Exactly+the+Same&type=recording&limit=25&method=direct


Oliver Charles added a comment - 25/Sep/12 05:06 PM

No, we have a back log of over a thousand tickets, it's simply unmanageable for a team of 3 to deal with that. So if I can't immediately reproduce it, then it serves no purpose having it lie around with nothing that can be done with it. Don't take me closing it as anything more than "I can't act on this" - reopening it is not something to be frowned upon, it just shows that it is still important.

Thanks for the new example.


Ian McEwen added a comment - 25/Sep/12 10:27 PM

I agree with voiceinsideyou – managing tickets is part of our job, and cursorily closing tickets without even trying to reproduce them is pretty disrespectful to the people who report bugs.

I agree that we have a backlog of tickets that's too large, but the solution to that is fixing things and finding duplicates, not offloading work that would have been trivial to volunteer bug reporters. If you don't have the time to make a real attempt at reproducing the ticket, leave a comment and leave the ticket open so someone will come back to it if you don't get a response – something that won't happen with tickets that are wontfix'd.


Oliver Charles added a comment - 26/Sep/12 09:50 AM

> without even trying to reproduce them

Yea, thanks for telling me what I do and don't do. I obviously just rampage through these tickets and just roll a dice.


Ian McEwen added a comment - 26/Sep/12 11:56 AM

By your own admission you just clicked the links (it only would have taken a.) noticing it wasn't actually a direct search at all, b.) ticking the box, and c.) re-hitting the search, to get a working page to reproduce the bug). I think I'm quite comfortable calling that no real attempt to reproduce the bug. Perhaps "without more than a cursory attempt at reproducing them" is more correct; the criticism stands.

Ultimately, everyone who files bugs is not as on top of things as voiceinsideyou; with many other potential reporters this bug would have stayed closed and languished in the wontfix bin probably forever (because really, who checks there to see if they happen to disagree with any of the wontfixes?).


Oliver Charles added a comment - 26/Sep/12 01:32 PM

Ultimately, everyone who files bugs is not as on top of things as voiceinsideyou; with many other potential reporters this bug would have stayed closed and languished in the wontfix bin probably forever (because really, who checks there to see if they happen to disagree with any of the wontfixes?).

I'm actually fine with that. If I've closed it and the original reporter doesn't verify it otherwise, then either it is fixed, or it's rare enough that it's not worth worrying about. If it's important someone will report it again. Note that this doesn't mean I will close things that I deem trivial - even trivial stuff that I can reproduce I leave open. Having a bug that can't be reproduced but "might" still be a problem is a waste of everyone's time. I really don't understand why people are getting so offended, getting closed as "cannot reproduce" is just me saying "I can't reproduce this, please take a look". I'm not making a personal attack.

I also realise now I wrote "wontfix" above which was not what I meant. I didn't mean "I won't fix this" I meant "I am unable to act on this ticket".

I don't think this ticket is the place to discuss this, if you feel strongly about the fact that I've apparently produced one false-negative (and even then, I think exactly what should have happened, has happened) then take this up on mb-devel.