Issue Details (XML | Word | Printable)

Key: MBS-2499
Type: Bug Bug
Status: Closed Closed
Resolution: Duplicate
Priority: Normal Normal
Assignee: voiceinsideyou
Reporter: Detlev Zundel
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Internal Server Error when trying to submit edit adding 4 CDs

Created: 02/Jun/11 08:33 PM   Updated: 07/Jun/11 03:52 PM   Resolved: 06/Jun/11 01:35 PM
Component/s: Release editor
Affects Version/s: None
Fix Version/s: None

File Attachments: 1. HTML File add2.html (62 kB) 05/Jun/11 01:10 PM - Detlev Zundel

Issue Links:
Duplicate
 


 Description  « Hide

Entering 4 (audiobook) CDs with lots of text for the titles results in

"Internal Server Error

Oops, something went wrong!

Error message: (No details about this error are available)

We're terribly sorry for this problem. Please wait a few minutes and repeat your request — the problem may go away."

I do not want to loose the edit - it took me half an hour to do, what should I do?



Sort Order: Ascending order - Click to sort in descending order
voiceinsideyou added a comment - 04/Jun/11 01:54 AM

The bug tracker is not for such questions requiring an immediate response.

In any case, I'm afraid in such situations the edit is lost. However in order to fix the root cause of the problem we need to know what you specifically did to trigger this. Were you trying to enter all 4 discs at once? Were they VA or single artist? Were you adding from some application originally?

I'm afraid that without specific details of how to replicate this it will have to be closed as there's nothing anyone can do to replicate the problem.


Anonymous MusicBrainz User added a comment - 05/Jun/11 07:11 AM

I encountered something similar. I tried to add a three disc release with mostly new (for MB) artists.

The source for it was:

http://thetubularnetgroup.weebly.com/disc-one.html
http://thetubularnetgroup.weebly.com/disc-two.html
http://thetubularnetgroup.weebly.com/disc-threebonus-songs.html

I cut and pasted the tracklists and reworked it so artists are correct. In the next step (add missing entities) MB times out.


voiceinsideyou added a comment - 05/Jun/11 09:13 AM

Getting a timeout/gateway error is completely different to an "internal server error". The timeouts are a known issue - see MBS-2126 and related tickets for "add missing entities" timeouts.


Detlev Zundel added a comment - 05/Jun/11 09:22 AM

I do still have the tab open with the edit and from time to time I try to save it and still
get the same error message, so I can reproduce this reliably.

As to the details - I tried to add the 4 CDs of an Audiobook (so single artist) all at once, yes. I needed
to create the author first. Each CD has ~29 titles with sometimes more than 100 characters.

Is this mode of operation not supported? How should I enter the data?


voiceinsideyou added a comment - 05/Jun/11 12:02 PM

Thanks for coming back to this and replying.

Are you always getting an Internal Server Error (as opposed to a Bad Gateway or other timeout)?

If so, which tab or button are you clicking at this stage, and which tab are you on?
Have you selected recordings or added new ones?
If you can get to the tracklist, can you post the tracklists here so someone else might be able to replicate?
Which steps did you go through to get to this stage? Were you submitting from a CD (e.g. via Picard originally) or from a cd stub? Or did you go to the artist and then click "add release"? Did you add existing tracklists in the "add disc" wizard, or manually enter titles/artists for all 4 discs?

You need to give all the information/steps required for someone to replicate - there are too many possible flows/steps for someone to guess what could create this unfortunately.


voiceinsideyou added a comment - 05/Jun/11 12:04 PM

To answer your question, the mode of operation is definitely supported, and you should never get an internal server error.

Another thought, if you newly added the artist, is it still in the DB? If not, it's possible to may have been auto-deleted (possibly prematurely, while you were still editing). Suggest you open up a new tab and do a separate search. If you could post the artist here too, that may help.


Detlev Zundel added a comment - 05/Jun/11 01:10 PM

Thanks for trying to clear up my confusion. As I still have the tab open with the "valuable"
entered text, I may try to re-add the entries later on again.

So let me try to state how I got here (as good as I remember). Originally I wanted simply to convert my audio CD,
so Sound Juicer under GNOME popped up. As it couldn't find the data, I considered adding
it, so I clicked on the "Submit Album" Button available there.

Actually I was kind of lost on the website on how to proceed from here. Even though I tried
to read the available documentation, I was not at all clear what to do now. Therefore my recollection is somewhat hazy, as this was all trial and error.

I think I started adding the data until I found that the artist "Michael Winterhoff" wasn't
even known, so I added him in a different browser tab. Then I added CD by CD in the edit page
until all data was entered. Next I pressed the "Enter Edit" button, which resulted in the error.

I'll attach the html page (on tab "Edit Note") that I extracted from my running browser session. Currently,
I admit that the artist got auto-deleted, so currently this cannot work, the error is still the "internal error". I'll try again later
when I have more time.

Thanks
Detlev


voiceinsideyou added a comment - 05/Jun/11 02:29 PM

OK, well I'm not so surprised that you're getting an internal server error now, as the system will have automatically deleted the artist you created. In theory it should only do so after x hours, and when there are no pending edits against it - however there have been some reports of prematurely deleted artists on the new MusicBrainz so it's possible that you were hit by this problem originally.

Anyway, we may be able to tell by getting you to try and successfully enter the current edit. I have added a replacement artist entry for you at http://musicbrainz.org/artist/33a19c0e-f50f-482e-a236-eba377c584f7 - this one shouldn't get deleted as I've added a relationship to it. So you'll now need to change your pending release entry to be against this artist instead of the one you earlier added. You'll need to go back to the first tab of the release editor and do another search for "Michael Winterhoff" there, locating the new artist I added. I think that if you then go back to the Edit Note tab and try submitting again, you might have more luck. Maybe!

Unfortunately you've got started with MusicBrainz at an unlucky time. The current system is only a coupla weeks old and is a massive change. Sound Juicer and other applications have some compatibility issues with the new MusicBrainz. The new MusicBrainz has many usability issues the team are working through and the documentation is out of sync with the website, so I'm not so surprised that you're a bit lost. It'll improve


Detlev Zundel added a comment - 06/Jun/11 08:43 AM

I could not find an easy way to change the artist but keep the current edit, so in the end
I had a furious copy & paste session ending in a new release: http://musicbrainz.org/release/fad599e1-57d2-4e27-a278-e16814cdb2b1

Unfortunately, now I do not know how to add the Disc IDs so that Sound Juicer "gets the
connection". Where can I find information on how to do this?


Detlev Zundel added a comment - 06/Jun/11 09:26 AM

Ah never mind, found it. In the previous iteration I erroneously clicked on the artist
found in the search instead of marking it with the radio button - pilot error.

Funnily enough as currently only CD1 has a Disc ID attached to it, Sound Juicer now
retrieves all 109 titles on insertion of disc 1.

Oh, this happens even after attaching all IDs to the individual discs

Is there anything wrong with the data that I entered, or should I report a bug to the
Sound Juicer people now?


voiceinsideyou added a comment - 06/Jun/11 01:35 PM

Yeah, that's because Sound Juicer (like most applications) is using the backwards-compatible version 1 web service against the new "version 2" schema, called NGS. In old MB each disc used to be a separate release, but now they are merged - so to Sound Juicer it looks like one big release. Picard 0.14 and earlier are affected by the same problem. I'm sure there is already enhancements raised against Sound Juicer to use the new MB web services that support these discs. In the meantime, you could try Picard 0.15 Beta which has been released with support for the new MB data model. (It doesn't rip CDs itself though)

Anyway, closing this as a dupe of MBS-2400 which appears like it was the root cause of this.


Detlev Zundel added a comment - 06/Jun/11 02:55 PM

I have to admit that I do not understand this. If something is backwards compatible
then it should continue to work. A functioning version scheme should prevent non-matching
components to try to work together. Neither seems to be the case here. But I agree that my
original problem is gone.


Oliver Charles added a comment - 06/Jun/11 03:39 PM

Detlev: I assume you're talking about Sound Juicer in regards to compat. The issue there is that the Sound Juicer bundled with Ubuntu (I assume you're on Ubuntu anyway) is built against a web service we deprecated years ago, and has now finally been removed entirely. You can compile it from source (with libmusicbrainz 3 support), or nag your distributions packaging team


voiceinsideyou added a comment - 06/Jun/11 04:41 PM

Fully backwards compatible is often very expensive in terms of server systems. MB does not have unlimited resources. It's not just a matter of magical versioning schemes when you completely change your database schema - sometimes the data has undergone migrations that cannot be resurrected to how it was before, which is what has happened in this case for releases merged to support multi-disc. Besides, I don't see that this is a big deal - you get all 109 files and you just tag the n files from that disc. Then the next n files? It's a minor annoyance to me, as a user and the well maintained software is already being updated, e.g. Picard.


Detlev Zundel added a comment - 07/Jun/11 07:32 AM

Oliver: Actually I'm using Debian/wheezy using Sound Juicer 2.32.0 is in there.

Chad: Please don't get me wrong - I realize the finiteness of resources to a project such
as MB and I appreciate the work that you guys put in, but from my perspective as a user
(not a developer), the situation that I experienced without doing anything special is just
not acceptable.

The "no big-deal" argument isn't really going very far.
Actually I tried manually de-selecting all tracks that are not on the disc currently in the
drive. Having done this for all 4 discs I really had files looking correctly
tagged. Unfortunately for discs 2-4 all files starting from number two contained the same
data This behaviour is simply worse than not working at all.


nikki added a comment - 07/Jun/11 01:40 PM

We already have a ticket - MBS-2407 - for problems with multi-disc releases and programs like Sound Juicer.


voiceinsideyou added a comment - 07/Jun/11 02:56 PM

Well you didn't actually mention anything earlier about Sound Juicer being unable to tag or work correctly as a result; you just mentioned that it retrieved all 109 files. I can't magically know you're describing a different or worse problem than you actually described. The same happens to Picard and it just matches your files to the subset of the 109 tracks; so it is "no big deal" for me as a user of Picard.


Detlev Zundel added a comment - 07/Jun/11 03:52 PM

Thanks for the follow-up Chad. Actually I didn't know about Sound Juicer not working correctly until
the time I wrote about it. I found out only by actually trying to listen to the converted files.
Programs not reporting such errors are IMHO not only broken, but actively malignant.

So if there are other client programs that can work with MB, then maybe one should warn people
of even using Sound Juicer? Anyway, thanks for the support.