Issue Details (XML | Word | Printable)

Key: MBS-2311
Type: Bug Bug
Status: Closed Closed
Resolution: Cannot Reproduce
Priority: High High
Assignee: Kuno Woudt
Reporter: Aurélien Mino
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Release editor: "An artist is required on track n" when seeding parameters to release editor

Created: 25/May/11 11:45 PM   Updated: 26/May/11 07:02 AM   Resolved: 26/May/11 06:27 AM
Component/s: Release editor
Affects Version/s: Hot fixes, 2011-05-25
Fix Version/s: Hot fixes, 2011-05-26


 Description  « Hide

Got the following error importing this discogs release http://www.discogs.com/release/1167884
using http://userscripts.org/scripts/show/36376 :

"Error: An artist is required on track 1, An artist is required on track 2"

As you can see, seeded parameters are the following ones:
<form target="_blank" method="post" action="http://musicbrainz.org/release/add"><input type="hidden" name="name" value="Le Chat"><input type="hidden" name="country" value="FR"><input type="hidden" name="date.year" value="1976"><input type="hidden" name="labels.0.name" value="Barclay"><input type="hidden" name="labels.0.catalog_number" value="620 175"><input type="hidden" name="artist_credit.names.0.name" value=""><input type="hidden" name="artist_credit.names.0.artist.name" value="Weyman Corporation"><input type="hidden" name="artist_credit.names.0.join_phrase" value=" "><input type="hidden" name="mediums.0.format" value="7" Vinyl"><input type="hidden" name="mediums.0.position" value="0"><input type="hidden" name="mediums.0.track.0.name" value="Le Chat"><input type="hidden" name="mediums.0.track.0.length" value="4:24"><input type="hidden" name="mediums.0.track.1.name" value="Kumbayero"><input type="hidden" name="mediums.0.track.1.length" value="4:58"><input type="hidden" name="edit_note" value="From http://discogs.com/release/1167884"><input type="submit" value="Import into MB"></form>

mediums.n.track.artist_credit are NOT seeded, because they're equal to the release one.
This was working fine yesterday, so maybe it's related to commit 3434fcf33f7ee4c429e7e30ab3563dfbd0207f32



Sort Order: Ascending order - Click to sort in descending order
Kuno Woudt added a comment - 26/May/11 06:26 AM

I cannot reproduce this on the "v-2011-05-25-ngs-hotfixes" tag or the production branch.

I CAN reproduce it on the "v-2011-05-24-ngs-hotfixes" tag.

So, I think the problem was introduced or not properly fixed in commit bd3004e0fa942d187ccb95efbc98d9f08295ca8b (MBS-2052). And it was fixed in 3434fcf33f7ee4c429e7e30ab3563dfbd0207f32 (MBS-1990).

The way I have tested this:

1. Open http://frob.nl/~warp/re/mbs-2311.html (this is the data copied from the description in this ticket)
2. Click "Import into MB"
3. Click next (I'm on the tracklist page afterward)
4. Click next (I'm on the recording page afterward)

When I do this on the v-2011-05-24-ngs-hotfixes branch I get the artist required messages on the tracklist page.


Aurélien Mino added a comment - 26/May/11 07:02 AM

I've been able to track the source of the issue.
http://frob.nl/~warp/re/mbs-2311.html is not the data copied from the description in this ticket, there's one big difference:
mine has a non empty join phrase (which is a bug in my gm script): <input type="hidden" name="artist_credit.names.0.join_phrase" value=" "> whereas yours is empty.

So what happens is that this non empty join phrase make the Release Editor unable to "valid" the artist credit on the "Release details" tab (the field is grey and if you open the artist creditor is has 2 artists, 2nd one being empty), and thus it causes problems in the following tabs.
However it doesn't warn you that the artist credit is invalid and allows you to go to following tabs.

Whether you think this is a bug or is by design is now up to you.
I'll go fix my greasemonkey script.