Issue Details (XML | Word | Printable)

Key: MBS-5540
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: Normal Normal
Assignee: Michael Wiencek
Reporter: Nicolás Tamargo
Votes: 1
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Release editor eats tracklists

Created: 01/Nov/12 03:06 AM   Updated: 28/Jan/13 10:15 AM   Resolved: 28/Jan/13 10:15 AM
Component/s: Release editor
Affects Version/s: None
Fix Version/s: 2013-01-28


 Description  « Hide

If I parse a tracklist and then change the track artists, the release editor doesn't like it and proceeds to eat my tracklist when I try to advance and tell me "But I need a tracklist!". It doesn't seem to be fully consistent (I'm fairly sure a few times it's worked) but it's happening quite often. For some reason, parsing the tracklist, advancing to the recording tab, then going back and changing the artists never causes problems.



Sort Order: Ascending order - Click to sort in descending order
Kuno Woudt added a comment - 28/Nov/12 03:02 PM

I cannot reproduce this problem. If this happens again, please add as much details as possible and re-open this ticket.


Nicolás Tamargo added a comment - 08/Jan/13 12:46 AM

Happening again, seems to be related to using http://userscripts.org/scripts/show/118491 to change the ACs just after parsing a tracklist. I know that might mean it's not directly a MBS issue, but since a) it points at something fishy going on and b) classical editing is pretty much impossible without that script anyway, it'd be great if this could get looked at.


Ian McEwen added a comment - 08/Jan/13 06:15 AM

reo: you might also point bitmap at this bug, given that's his script but I agree this suggests there's something fishy in the RE itself too.


Michael Wiencek added a comment - 08/Jan/13 09:56 PM

I tested this on a few existing releases, and on a new one (parsing tracklist, then changing artists with the script) and I didn't encounter any issue. I can look into it further, but need a release that it always breaks on (with steps on how to break it).


Nicolás Tamargo added a comment - 09/Jan/13 12:00 PM

Release artist: [{"gid":"a4eba7b5-aceb-4acf-b297-3c0a3cd42757","id":"41542","name":"Александр Николаевич Скрябин","sortname":"","credit":"Alexander Scriabin","join":"; "},{"gid":"c6c4103b-cf07-42ad-91a7-b7eab7586e56","id":"245008","name":"Royal Scottish National Orchestra","sortname":"","credit":"Scottish National Orchestra","join":", "},{"gid":"8a1d9496-603f-40b1-a38d-2e8985834940","id":"45573","name":"Neeme Järvi","sortname":"","credit":"","join":""}]

Parsed tracklist:

1 Symphony no. 2 in C minor, op. 29: I. Andante - 5:41
2 Symphony no. 2 in C minor, op. 29: II. Allegro 9:13
3 Symphony no. 2 in C minor, op. 29: III. Andante 11:30
4 Symphony no. 2 in C minor, op. 29: IV. Tempestoso - 5:30
5 Symphony no. 2 in C minor, op. 29: V. Maestoso 7:52
6 Rêverie, op. 24 3:48

Once parsed, use script to leave track artist as:

[{"gid":"c6c4103b-cf07-42ad-91a7-b7eab7586e56","id":"245008","name":"Royal Scottish National Orchestra","sortname":"","credit":"","join":", "},{"gid":"8a1d9496-603f-40b1-a38d-2e8985834940","id":"45573","name":"Neeme Järvi","sortname":"","credit":"","join":""}]

(no credit as for the orchestra as opposed as in release artist).

Click the Edit Note tab.

This has eaten my tracklist twice in different sessions so I hope you can reproduce it!


Michael Wiencek added a comment - 09/Jan/13 07:42 PM

Huh, still nothing so far. I tried the above steps 3 times on mb.org and 3 times on beta, in Chrome 23.0.1271.101, plus once in Firefox just to be safe.


Nicolás Tamargo added a comment - 09/Jan/13 08:06 PM

Hmm. Try manually removing the stuff from the track artist rather than directly copying that credit (so, removing the composer and removing the "credited as" for the orchestra). If that doesn't do it either, I give up


Michael Wiencek added a comment - 09/Jan/13 08:38 PM

Aha! Yeah, it consistently breaks if I edit the artists manually rather than with the script. I also tried everything by hand, without the script loaded, and it still breaks, which means it shouldn't be a problem with my script at all (phew). The script just makes it easier to reproduce.


Michael Wiencek added a comment - 09/Jan/13 09:50 PM

Hopefully warp doesn't mind me stealing this ticket from him, but since I already spent time debugging it...

http://codereview.musicbrainz.org/r/2494