Issue Details (XML | Word | Printable)

Key: MBS-355
Type: New Feature New Feature
Status: Closed Closed
Resolution: Duplicate
Priority: High High
Assignee: Oliver Charles
Reporter: Meloria
Votes: 0
Watchers: 0
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Pagination needs a better concept

Created: 02/Feb/10 02:47 PM   Updated: 06/Feb/10 01:03 PM   Resolved: 06/Feb/10 01:03 PM
Component/s: None
Affects Version/s: None
Fix Version/s: None

Issue Links:
Duplicate
 


 Description  « Hide

(I expect that something like this has already been considered; didn't see anything about this on the issue tracker, though.)

Pagination is mostly a safety thing in that it saves both the server and the end-user from handling too large data sets. However, ironically, the usability of pagination gets worse and worse with the number of pages it needs to handle.

This is less of a problem for Pop/Rock artists since there are not too many pages anyway and for the majority of cases a practical sorting order can be found. That is, putting the regular albums on top and compilations to the bottom. That is how I think it should be done, even though already for these artists, a 'show all releases on one page' is really needed.

But now have a look at http://test.musicbrainz.org/artist/24f1766e-9635-4d58-a4d4-9413f9f98a4c . It's 32 pages! And even worse: when searching a classical release you'd actually need to look into the compilations section in many cases. (Either because it actually is a compilation or because it has just been put there by a user as stopgap.) So basically, when people search a classical release, they do not have the slightest idea on which page where they should start. (On the old site, I'd usually do a page search and hope that the contributor of the release handled the TitleStyle well, so that I'd have a chance of getting the release.)

My suggestion (apart from the 'show all' or 'show next 1000' button) would be a live search/filter which could be used for thinning out the releases. And of course it should take care of more release attributes than just the title.



Sort Order: Ascending order - Click to sort in descending order
nikki added a comment - 02/Feb/10 02:49 PM

Is this a duplicate of MBS-341?


Meloria added a comment - 02/Feb/10 02:57 PM

It's the same problem but a different solution. Actually I'd want to have both solutions at the same time.


Oliver Charles added a comment - 06/Feb/10 01:03 PM

Meloria, I'm going to mark this as a dupe of MBS-341, and we can plan an appropriate solution there. Please watch that issue!