Issue Details (XML | Word | Printable)

Key: MBS-3499
Type: Bug Bug
Status: Closed Closed
Resolution: Fixed
Priority: High High
Assignee: Oliver Charles
Reporter: Anonymous
Votes: 0
Watchers: 1
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Encoding error - couldn't render template...

Created: 22/Sep/11 03:41 AM   Updated: 03/Oct/11 11:01 AM   Resolved: 03/Oct/11 11:01 AM
Component/s: Data display, Templates
Affects Version/s: None
Fix Version/s: Bug fixes, 2011-09-26

Issue Links:
Relates
 
Resolution
 


 Description  « Hide

Error:

Couldn't render template "undef error - Unknown encoding: gb18030 at /usr/local/lib/perl/5.10.1/Encode/Detect.pm line 54.
"

Stack trace:

line 16 MusicBrainz::Server::View::Default
line 270 MusicBrainz::Server

Request data:

$VAR1 = {
'query_parameters' => {},
'body_parameters' => {}
};

URL: http://musicbrainz.org/artist/3920b814-c7a0-4da9-932e-613b708db48b



Sort Order: Ascending order - Click to sort in descending order
voiceinsideyou added a comment - 22/Sep/11 05:35 AM

Think this one needs a hotfix...


voiceinsideyou added a comment - 22/Sep/11 05:53 AM

GB 18030 is the Chinese government standard, whereas this artist is "Lula Côrtes" so perhaps it's an encoding detection issue? http://classic.musicbrainz.org/show/artist/?mbid=3920b814-c7a0-4da9-932e-613b708db48b

Stack trace on test indicates it could be a problem with external links section, but then again rendering edits in edit search is also broken:

http://musicbrainz.org/search/edits?order=desc&auto_edit_filter=&negation=0&combinator=and&conditions.0.field=artist&conditions.0.operator=%3D&conditions.0.name=Lula+C%C3%B4rtes&conditions.0.args.0=796153&conditions.0.user_id=137798&field=Please+choose+a+condition

Lowering priority back as perhaps it it's possible it was an issue prior to this release I guess?


Oliver Charles added a comment - 22/Sep/11 01:19 PM

This is a regression caused by a bad solution to MBS-2911. It's in review at http://codereview.musicbrainz.org/r/1547/ and available for testing on http://test.musicbrainz.org - hopefully we can get a fix rolled out tonight.


voiceinsideyou added a comment - 22/Sep/11 02:01 PM

Cool, looks better there