Issue Details (XML | Word | Printable)

Key: MBS-2194
Type: Improvement Improvement
Status: Closed Closed
Resolution: Won't Fix
Priority: High High
Assignee: Unassigned
Reporter: Aurélien Mino
Votes: 2
Watchers: 2
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Release editor "Don't misassociate tracks <-> recordings relations" feature (MBS-661) doesn't work

Created: 21/May/11 07:24 PM   Updated: 04/Sep/12 08:05 PM   Resolved: 04/Sep/12 08:05 PM
Component/s: Release editor
Affects Version/s: Hot fixes, 2011-05-20
Fix Version/s: None

File Attachments: None
Image Attachments:

1. recordings.png
(9 kB)

2. tracklist-after.png
(6 kB)

3. tracklist-before.png
(6 kB)
Issue Links:
Relates
 


 Description  « Hide

It doesn't ask any confirmation, but create new recordings.
This is what happened here: http://musicbrainz.org/edit/14481795
I swapped titles of tracks 1 & 2.
I got no question/confirmation for recordings 1 and 2, but new recordings have been silently created.
I did not change anything for track 3 & 4, but sill, new recordings have been silently created.



Sort Order: Ascending order - Click to sort in descending order
Kuno Woudt added a comment - 25/May/11 12:36 PM - edited

I cannot reproduce this.

I have attempted the following on both the production branch and the "v-2011-05-20-ngs-hotfixes-1" tag which is the affected release according to this ticket:

1. open http://localhost:3000/release/d9207330-8a89-302a-9d7b-05b85015b896/edit
2. click Tracklist tab (basic view opens)
3. replace 1 in "1. SomeName 1 - MusicBrainz Test Artist" with 2 (in the title, not the track number)
4. replace 2 in "2. SomeName 2 - MusicBrainz Test Artist" with 1 (in the title, not the track number)
5. click Recordings tab (all recordings still associated, recordings for track 1 and 2 swapped)
6. click Edit Note (edit preview also looks correct)

The edit preview is a bit messed up in the 2011-05-20 release, but looks correct on the production branch.

I was testing using Firefox 4.0.1 on the latest stable Debian GNU/Linux.

If this problem has not been solved, please re-open this ticket and add a more details.


Aurélien Mino added a comment - 25/May/11 12:53 PM

Reproduced on mb.org:

0. make sure you're using Advanced view of Tracklist by default
1. open http://musicbrainz.org/release/d9207330-8a89-302a-9d7b-05b85015b896/edit
2. click Tracklist tab (advanced view opens)
3. replace 3 in "3. SomeName 3 - MusicBrainz Test Artist" with 4 (in the title, not the track number)
4. replace 4 in "4. SomeName 4 - MusicBrainz Test Artist" with 3 (in the title, not the track number)
5. click Next, recordings tab opens (all recordings still associated, recordings for track 3 and 4 NOT swapped)
6. click Edit Note (edit preview also looks incorrect)


Kuno Woudt added a comment - 25/May/11 07:47 PM

right, that works as designed. the advanced view let's you edit the tracks directly, the recordings tab in that case just keeps the associated track. perhaps it should start guessing in that case too, but we'll have to discuss that.


Aurélien Mino added a comment - 25/May/11 08:55 PM

Then the design is broken.


Oliver Charles added a comment - 12/Jan/12 10:43 PM

As this issue has been delayed, I am moving it back to be rescheduled.


Aurélien Mino added a comment - 04/Sep/12 08:05 PM

No really reproducible now, since tracks positions are not editable anymore.