Issue Details (XML | Word | Printable)

Key: MBS-1837
Type: Improvement Improvement
Status: Closed Closed
Resolution: Fixed
Priority: High High
Assignee: Michael Wiencek
Reporter: Oliver Charles
Votes: 18
Watchers: 19
Operations

If you were logged in you would be able to see more operations.
MusicBrainz Server

Allow relating to works from the batch "relate to tracklist" page

Created: 12/May/11 12:47 PM   Updated: 16/Oct/12 10:14 PM  Due: 19/Feb/12   Resolved: 16/Oct/12 09:37 PM
Component/s: User interface
Affects Version/s: NGS - Final
Fix Version/s: Schema change, 2012-10-15

File Attachments: None
Image Attachments:

1. addworks.png
(349 kB)
Issue Links:
Depends
 
Relates
 

Size Estimate: Country


Sort Order: Ascending order - Click to sort in descending order
PATATE12 added a comment - 17/May/11 08:55 AM

If this is what would allow

« REGRESSION : lyrics/compo/arrange crediting can not be done any more from release page »

then you have my vote.


nikki added a comment - 18/May/11 11:57 AM

the most basic thing I would do is shown in the image I just attached (where the lines with boxes are the works linked to the recordings)
for extra functionality, links could be added to the right of the work name where a) the new work's name can be edited, b) another work can be added and/or c) the existing work can be looked up again to change it


Oliver Charles added a comment - 01/Jun/11 02:28 PM

This is now in for code review at http://codereview.musicbrainz.org/r/1284/, but I would also like fairly extensive testing to be done as well. This is available for testing on http://test.musicbrainz.org. Navigate to an artist page and click "use in relationship" then navigate back to a release page and click "relate artist to works"

Open questions:

  • Should we always allow creating a work? At the moment you can only create a work if a recording has no work relationships.

PATATE12 added a comment - 01/Jun/11 03:28 PM - edited

Thanks very much Oliver, it works for me, haha.

Now just waiting for the associated MBS-840 which will display all those (works AR+recording AR+puid+isrc+etc.) right in the release page.


David Hilton added a comment - 04/Jul/11 11:02 PM

Problems:
In it's current state, this doesn't allow /relating/ to works so much as /creating/ new works.

Works are always created, with no optional matching to similarly-named works (or their aliases).


nikki added a comment - 04/Jul/11 11:35 PM

That was already brought up on the code review linked a couple of comments before. We don't really know how to implement lookup - that's why it's still not been released.


lorenz pressler added a comment - 05/Jul/11 11:34 AM

what has been implemented on test works so far. however a few remarks:

minor:

  • textfield for input of workname is too small (if works have to be created).
  • if i don't check any of the recordings maybe it should give a warning that nothing was selected.
    major:
  • if works are created: since work and recording are linked together in this process, we would need to be able to set the attributes for this relationship also (date/partial/live/...).
  • textfield for workname should be searchfield to minimize the creation of work duplicates.
  • also the "Relate to ..." should let link to works.

PATATE12 added a comment - 05/Jul/11 12:02 PM

major :

+ If work is created, we should be able to set its attributes such as iswc, type, comment.

  • « also the "Relate to ..." should let link to works » is asked in MBS-2760.

Nicolás Tamargo added a comment - 26/Jul/11 09:49 AM

It could have "Search for a work [search field] or [ ] create a new work instead [text field]" ([ ] being a checkbox). If a work is selected in the search field, it should load its current relationships under it to avoid duplication and allow checking the work is indeed the correct one.
I don't think the text fields need to be bigger, though: you can just move inside them.

I can't think of a beautiful way to add the attributes for the relationship, so maybe some more checkboxes under the "create a new work instead" would have to do for now until somebody came up with a better way. But this is so basic that as long as it works, it should be released even if it's the ugliest thing in the world.

Setting extra work info can probably be done afterwards from the work page. We don't even allow adding all the artist / label info from the RE now and we have plenty of space there, vs. not so much here...


Oliver Charles added a comment - 09/Aug/11 08:46 PM

Josh added a comment - 20/Aug/11 08:54 PM

Awesomesaurus! One little thing though:

When I click on 'Relate to works' I get the following message:

'Please first navigate to the page of the artist who you wish to relate to recordings on this release and select "use in relationship"'

The word 'recordings' should be adjusted to 'works' and as I'm nitpicking anyway it would be great if you could change it to '"Use in relationship"' (with an uppercase 'U') and then add a full stop at the end of the sentence.


Oliver Charles added a comment - 22/Aug/11 11:38 AM

Sorry guys, but this isn't going to make this weeks release. It'll be at the front of my queue for next week.


Oliver Charles added a comment - 18/Nov/11 06:00 PM

It's a biggy, given by how much I've been slacking on it! But should definitely be considered for the upcoming versions.


Oliver Charles added a comment - 09/Feb/12 01:27 PM

Hi!

We need to work out a solution for various problems about creating relationships with works. The general problems are:

  • As a user, it's hard to create works for recordings, once you've added a release (you have to go to each recording one by one).
  • As a user, it's hard to create links from works to artists such as composition credits

In the last meeting on Monday [1] I announced that I was really struggling with this, and that I could do with a hand. Could you try and come up with a proposal for how this problem can be addressed? As much information as possible is best, and any examples/mockups would really help.

There are generally 2 approaches - a big relationship editor that can do all of this at once, or separate pages to do special actions - such as one page for creating/relating works, and one for creating artist-work relationships.

If you could take a look at this, it'd be really helpful.

[1]: http://chatlogs.musicbrainz.org/musicbrainz-devel/2012/2012-02/2012-02-06.html#T20-30-47-729390


Jim DeLaHunt added a comment - 09/Feb/12 05:25 PM

Oliver, thank you for your work on this issue. I read the chat log. I agree, it's a large problem.

One thing I'll point out is that this problem looks different for classical, and maybe jazz and musicals, than for pop recordings.

I suspect that most pop recordings have works which are being published for the first time, so that the Work will be entered into MBrainz together with the Release. In contrast, almost all classical recordings have Works which have been published before. Some Release will represent the first time that Work enters MusicBrainz, but every future Release will be seeking a Work which already exists in MusicBrainz.

Thus, for classical and maybe jazz and musicals, it makes perfect sense to have one UI for defining works and a different UI for attaching Releases (or Recordings) to Works which are already in MusicBrainz.

I hope this helps chip one flake of complexity away from the boulder.


Oliver Charles added a comment - 01/Oct/12 10:19 AM

This failed beta testing so has been reverted and moved to the next release.


Ian McEwen added a comment - 16/Oct/12 09:37 PM

Fixing fix version; this wasn't added back to "in beta testing" when it was added back to beta.


Ross Collins added a comment - 16/Oct/12 10:05 PM

If this is indeed fixed then how do I do it? I had a look both on the main site and the beta site, and it wasn't clear to me how this is now implemented.


Nicolás Tamargo added a comment - 16/Oct/12 10:14 PM

"Edit Relationships" on the release sidebar. A how-to for it coming (hopefully) tomorrow.